nynw.net
当前位置:首页 >> jquEry 在有些IE8下是否不兼容 >>

jquEry 在有些IE8下是否不兼容

当然有不兼容的地方啊,但只是极少数地方,也要看看你的jquery包都是哪个版本的~ 建议用1.8.3版本最稳定,1.4.3也是个稳定版本。但用新不用旧还是1.8.3吧,2.0后都不支持IE 6 7 8了

var kx_shipping = $("input[class=tradio]:checked").parent().next().text(); 声明的有问题吧 html()是替换ID为shipping元素下的html代码 而你kx_shipping声明出来的值只有在这个script闭合元素下才能执行 ID为shipping元素里面的值只能是html...

你好,很高兴为你作答。 对于IE 8 来说,jquery的低版本是可以兼容的。 不过在2.0版本之后,官方已经宣布不再支持IE 6 7 8版本的浏览器。 所以,使用诸如比较常用的1.4、1.7版本的jquery,在IE 8下面使用是没有问题的。

2.0以上版本的jQuery已经不再支持IE8及以下版本的IE浏览器,所以才出现了问题。 解决方法很简单: 相关问题: Jquery从2.x版本开始已经不再进行IE低版本(IE6、IE7、IE8)的兼容性处理。如果需要兼容低版本的IE版本,建议使用原生JS或者低版本的Jqu...

楼主不说明使用版本,猜测可能是版本的问题。 复制一段 jQuery 官网的原话: jQuery 2.x has the same API as jQuery 1.x, but does not support Internet Explorer 6, 7, or 8. 2.x 版本不兼容 IE6,7,8 网上也有一个。 博客园闪存分页是用Jav...

ie来说 你jquery语法必须规范化,否则就报错。当初ajax我就碰到不能使用url链接参数传递,报错。

这两个都是jquery库,只是版本不同而已,所以只需要引入一个就行了。其中1.3.2是版本非常低的jquery了,应该丢弃了,还是只导入1.9.1吧。如果还有因此导致哪个效果没了,那就换个插件吧,可能是因为你现在用的插件使用了较低版本的jquery。

没有冲突,jQuery目前就只有2.0以上的版本不支持1E6,7,8,1.X版本还是支持的,我现在做项目都在用1.11.

jQuery 2.x 就是针对 IE9 以上的。 兼容 IE 低版本 还是用 jQuery 1.x 版本吧。 https://code.jquery.com/jquery/ 这是 jQuery 所有版本。

jQuery新版本已经不再进行IE低版本(IE6、IE7、IE8)的兼容性处理。 如果项目需要兼容IE低版本,需要使用jQuery1.x版本,从2.x开始已经不兼容IE6、7、8了。 以下为jQuery官网的通知: jQuery 2.x has the same API as jQuery 1.x, but does not su...

网站首页 | 网站地图
All rights reserved Powered by www.nynw.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com